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IRIS 2021 技�文档 First Look 3 - �接一个IDE
InterSystems IRIS 基�：�接一个 IDE

本文档告�您如何快速�接您的集成开��境（IDE），用于 ObjectScript、Java、.NET、Python 或
JavaScript/Node.js 的集成开��境�接到 InterSystems IRIS® 的一个�例，并使用从 GitHub
下�的模板文件��您是否已�成功�接。
此外，接下来的两��包括以下内容：
•   部署 InterSystems IRIS
列出用于部署 InterSystems IRIS
的已授权和免��估�例的��。如果您�没有一个可以使用的�例，��看本�。
•   InterSystems IRIS �接信息
��介�了将 IDE �接到已授权或免�的 InterSystems IRIS �例，以及以其他方式与之�行交互所需的信息
，并解�了如何�得�例的信息。无�您想用哪个 IDE �接到 InterSystems
IRIS，都要�看涉及您所使用的�例类型的部分。

1   部署 InterSystems IRIS
本�涵盖了已授权的�例和免�的�估�例。

1.1   部署已授权的�例
如果您已�从 InterSystems ��了一个或多个�可�，您可以使用以下方法之一来部署一个已授权的 InterSystems
IRIS �例：
•   InterSystems 云管理器
•   InterSystems Kubernetes Operator
•   InterSystems IRIS 容器�像
•   InterSystems IRIS 安装套件

当从容器�像或安装套件�行部署�，您可以使用配置合并功能 来支持自�部署。

1.1.1   InterSystems 云管理器
InterSystems 云管理器（ICM）是 InterSystems IRIS 的端到端配置和部署解决方案。使用
ICM，您可以在公共云平台（如谷歌云平台、���网�服�和微� Azure）或您的私有 VMware vSphere 云中配置
基��施和部署容器化服�，您也可以在�有的虚�或硬件系�中部署服�。您可以将您的自定�和第三方容器与
InterSystems 的容器一起部署，而且 ICM �可以从 InterSystems IRIS 安装套件中安装。
 
部署 InterSystems IRIS

关于 ICM 的��文档，�参� InterSystems Cloud Manager Guide（《InterSystems
云管理器指南》）。您可以通个First Look: InterSystems Cloud Manager（《技�概要：InterSystems
云管理器》）�用 ICM。关于如何�得和部署 ICM �像的信息, �参�InterSystems Cloud Manager
Guide（《InterSystems 云管理器指南》）中的Launch ICM（启� ICM）。

1.1.2   InterSystems Kubernetes Operator
Kubernetes 是一个开源的�配引擎，用于自�化部署、�展和管理容器化工作��和服�。您可定�您想要部署的
容器化服�和想要使用的治理策略；Kubernetes
以最有效的方式透明地提供所需的�源，在部署偏离�格�修复或恢复，并自�或按需�展。InterSystems
Kubernetes Operator（IKO）通� IrisCluster 自定��源�展了 Kubernetes API，��源可以在任何 Kubernetes
平台上作� InterSystems IRIS 分片集群、分布式�存集群或独立�例（所有可��像）�行部署。IKO ��
Kubernetes 增加了 InterSystems IRIS 特定的集群管理功能，��了任�的自�化
，如向集群添加�点，否�您必�通�与�例直接交互来手�完成。关于使用 IKO 的信息，�参�Using the
InterSystems Kubernetes Operator（《使用 InterSystems Kubernetes Operator》）。
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1.1.3   InterSystems IRIS 容器�像
InterSystems 的 Docker �像�您可以使用自己的工具和方法将 InterSystems IRIS 部署到 Linux
主机̶̶云、虚�或物理主机上的容器中。�特定�例数据的持久性存�使容器化的 InterSystems IRIS
易于升�，因此您可以随�将�有的配置�移到最新版本的 InterSystems IRIS
中，而几乎不存在任何��，停机��也很少。
关于使用 InterSystems IRIS �像的��指南，�参�Running InterSystems Products in
Containers（《在容器中运行 InterSystems �品》）。如果想�身体�一下 InterSystems IRIS
�像和容器，���First Look: InterSystems Products in Containers（《技�概要：容器中的 InterSystems
�品》）。关于如何�得 InterSystems IRIS �像的信息，�参�Running InterSystems Products in
Containers（《在容器中运行 InterSystems�品》）中的Downloading the InterSystems IRIS Image（《下�
InterSystems IRIS �像》）。
您可以使用安装在谷歌云平台、微� Azure 或���网�服�公共云平台上的 InterSystems IRIS 容器�像和
Docker 来配置 BYOL（自��可�）云�点, 然后添加您的�可并按照Running InterSystems Products in
Containers（《在容器中运行 InterSystems �品》）或First Look: InterSystems Products in
Containers（《技�概要：容器中的 InterSystems �品》）中的描述，从��像中运行 InterSystems IRIS
容器。欲了解更多信息，�参�Deploy and Explore InterSystems IRIS（《部署和探索 InterSystems
IRIS》）中的Deploy InterSystems IRIS BYOL on a Cloud Node（《在云�点上部署 InterSystems IRIS
BYOL》）。(您也可以使用免�的 InterSystems IRIS 社区版�像来使用�些文档。）

1.1.4   InterSystems IRIS 安装套件
您可以通�从 InterSystems 全球响�中心
(WRC)下�区�得您的平台的最新安装套件，在您的本地机器或网�上的另一台机器上安装和�可 InterSystems
IRIS 的开��例。有关基本的安装�明，�参� InterSystems IRIS Basics: Installation （《InterSystems IRIS
基�：安装》）；��信息�参�安装指南。

1.1.5   使用配置合并�行部署
配置合并功能在 Linux 和 UNIX®系�上可用，�您可以改�从同一�像部署的 InterSystems IRIS
容器的配置，或从同一套件安装的本地�例，只需��地将所需的声明性配置合并文件�用于部署的每个�例。
�个合并文件, 也可以在重启�有�例或使用 iris 合并命令��用，更新�例的配置参数文件 (CPF),
其中包含了大部分的配置�置；�些�置在每次启��都会从 CPF �取，包括�例部署后的第一次启�。当您在部
署�程中�用配置合并�，��上是用您自己的更新版本替�了随�例提供的默� CPF。
InterSystems 云管理器 和 InterSystems Kubernetes Operator 都包含了配置合并功能。
 
InterSystems IRIS �接信息

有关使用配置合并的信息，�参�Configuration Parameter File Reference.（配置参数文件参考）中的Using
Configuration Merge to Deploy and Reconfigure InterSystems IRIS（使用配置合并来部署和重新配置 InterSystems
IRIS）和Create and Use a Configuration Merge File（�建和使用配置合并文件）。

1.2   部署免�的�估�例
如果您�不是 InterSystems IRIS 的用�，您可以通�部署一个免�的�估�例，来探索它的�多功能，并使用您喜
�的�言和工具以及您自己的代�来�用它。有以下几个��可以做到�一点：
•   在云或者您自己的系�上部署 InterSystems IRIS 社区版�例。
•   在网上启�一个 InterSystems 学���室（Learning Labs）�例。

1.2.1   InterSystems IRIS 社区版
InterSystems IRIS 社区版有一个免�的内置 13
个月的�可�（和一些功能限制）。您可以通�两种方式部署社区版：
•   在谷歌云平台、微� Azure 或���网�服�公共云平台上提供一个托管运行社区版容器的云�点。
•   从 InterSystems Container Registry (ICR)或 Docker Store
中提取社区版�像，并使用它在您��的系�上部署容器。

有关在云或自己的系�上部署和使用 InterSystems IRIS 社区版的�明，�参�Deploy and Explore InterSystems
IRIS（《部署和探索 InterSystems IRIS》）。

1.2.2   InterSystems 学���室（Learning Labs）
InterSystems 学���室（Learning Labs）网�可以�您快速、�松地启� InterSystems IRIS
��室�例，用于培�、开�和��，并有 30 天的免��可。您的 InterSystems 学���室�例包括一个集成的
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IDE 和大量的示例，您可以�接您自己的 IDE。
要启� InterSystems 学���室�例，您必�登� learning.intersystems.com；如果您没有��，可以�松�建一
个。(与社区版一�，学���室�例有一些功能限制。)

2   InterSystems IRIS �接信息（Connection Information）
要将一个 IDE �接到一个 InterSystems IRIS �例，首先需要���例，然后确定所需的�接信息，如下所示：
•   主机��符：�例主机的 IP 地址或主机名。
•   �例的超�服�器和 web 服�器端口号。
•   �例的有效凭�。
•   �例上�有命名空�的名称。

了解�例基于 Web 管理門�的 URL，以及如何在�例上打开 InterSystems �端
（�需要�例的名称），�也是很有帮助的。
如何确定�些信息取决于您如何部署您正在使用的�例，如下所示：
•   InterSystems 云管理器（Cloud Manager）
 
InterSystems IRIS �接信息

•   在一个容器中部署 InterSystems IRIS
•   从套件中安装 InterSystems IRIS
•   InterSystems IRIS 社区版
•   InterSystems 学���室（Learning Labs）

2.1   InterSystems 云管理器（Cloud Manager）
�于由 ICM 部署的容器中的 InterSystems IRIS �例，主机��符是容器所部署的配置或�有�点的 IP
地址或主机名。您可以随�使用 icm inventory 命令�看您部署的�点的主机名和 IP 地址。
默�的超�服�器和 Web 服�器端口号分别� 1972 和 52773；您可以通�在 defaults.json 文件中加入
SuperServerPort 和 WebServerPort 属性来指定不同的端口号。管理門�的 URL 門�包含了主机��符和 web
服�器端口，例如 http://40.122.36.160:52773/csp/sys/UtilHome.csp。IDE
�接或管理門�的凭�是您在基��施上用 icm run
命令部署服���置的�定�用���之一和默�密�，或者是您先前添加到�例的��和密�。
要打开 ICM 部署的�例的�端，可以使用�有-interactive ��和 -machine ��的 icm session 命令
，指定托管�例的�点；不需要��。
您始�可以将您的 IDE �接到所有 InterSystems IRIS �例中存在的 USERnamespace,但是如果您在部署�使用了
definitions.json 文件中的 Namespace 属性或 -namespace ��以指定不同的默��行命名空�,
您可能希望�接到�namespace。您�可以�接到以前使用管理門��建的其他名称空�。

2.2   在一个容器中部署 InterSystems IRIS
�于您从 InterSystems �像（包括在 BYOL 云�点上）部署的容器中的 InterSystems IRIS
�例，主机��符是容器所运行的系�的 IP 地址或主机名。
超�服�器和 Web 服�器的端口号取决于您在用 docker run
命令�建和启�容器�如何�布�例的端口；更多信息，�参�Running InterSystems Products in
Containers（《在容器中运行 InterSystems �品》）中的Running InterSystems IRIS Containers（运行
InterSystems IRIS 容器）。�个例子，如果您把�例的 Web 服�器端口（始�是 52773）�布�
52773（如引用部分所述），并且您的��器与容器在同一个系�上运行，那么管理門�的 URL 是
http:/localhost:52773/csp/sys/UtilHome.csp。IDE
�接或管理門�的凭�是您在�建容器��置的�定�用���之一和默�密� [�参�Running InterSystems
Products in Containers（《在容器中运行 InterSystems �品》）中的Authentication and
Passwords（��和密�）]，或者是您先前添加到�例中的��和密�。
要�容器中的�例打开Terminal，您可以使用 docker exec 命令在容器中运行 iris terminal命令，您也可以使用
docker exec 在容器中打开一个 shell，并从那里运行 iris ternimal ；有关示例，�参�Deploy and Explore
InterSystems IRIS（《部署和探索 InterSystems IRIS》）中的Interacting Using the InterSystems Terminal（使用
InterSystems Terminal�行交互）。要使用 iris terminal，您需要�例名称，在 InterSystems
的任何容器中，�名称始�� IRIS。如Running InterSystems Products in Containers（《在容器中运行
InterSystems �品》）中的Ownership and Directories（所有权和目�）所述，使用 docker exec 从 InterSystems
IRIS 容器外�出的命令在容器内以 irisowner 身份�行，不需要身份��，因此您无需登�Terminal。
您始�可以将您的 IDE �接到存在于所有 InterSystems IRIS �例中的 USER
namespace，但您也可以�接到您先前使用管理門��建的不同的namespace。
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InterSystems IRIS �接信息

2.3   从套件中安装 InterSystems IRIS
�于从套件中安装的 InterSystems IRIS �例，主机��符是��例运行的系�的主机名或 IP
地址；如果是本地安装，可以使用 localhost 。
InterSystems IRIS 的安装将超�服�器和 web 服�器的端口号默��置� 1972 和
52773。但是，如果您在系�中安装了一个以上的 InterSystems IRIS �例，那么�些�例的超�服�器和 web
服�器的端口是不同的；要�示所有�例的端口号，您可以在操作系�的命令行中使用 iris list 命令。
在 Windows 系�中，您可以通�点�系�托�中的 InterSystems IRIS ��并�� Management Portal
来打开管理門�。在所有系�上，您都可以使用 URL http://host:webserverport/csp/sys/UtilHome.csp, 其中 host
是主机��符， port 是 web 服�器端口号, 例如 http://localhost:52773/csp/sys/UtilHome.csp。
要打开已安装�例的�端： 
•   在 Windows 系�上, 您可以�� InterSystems IRIS 启�菜�上的 Terminal ��。
•   在所有的系�上，您可以在操作系�的命令行上使用 iris
terminal命令，把�例名称作�参数。�例名称是在您安装�例��置的，不能更改；您可以使用 iris list
命令来�示它。

用于所有目的的凭�是�定�用���（predefined user accounts）之一和默�密�
SYS（��做后会提示您立即更改��的密�），或者是您先前添加到�例的��和密�。
您始�可以将您的 IDE �接到存在于所有 InterSystems IRIS �例中的 USER
namespace，但您也可以�接到您先前使用管理門��建的不同的namespace。

2.4   InterSystems IRIS 社区版
您可以通�以下两种方式之一部署社区版：
•   当您在公共云平台上配置托管运行的 InterSystems IRIS 社区版容器的云�点�, 云�点的 IP
地址（主机��符）、�例的超�服�器和 Web 服�器端口号（始�分别� 1972 和
52773），以及�例的管理門� URL 在您首次使用 SSH �接到�点��示，并且可以通�在 Linux 命令行上�入
iris info 随��示。門�网站的 URL 包含了 IP 地址和 web 服�器端口，例如 
http://40.122.36.160:52773/csp/sys/UtilHome.csp。
•   当您从 InterSystems Container Registry 或 Docker Store 提取社区版�像并在您��的系�上部署 InterSystems
IRIS 社区版容器�，主机��符是容器运行所在系�的 IP 地址或主机名。超�服�器和 Web
服�器的端口号取决于您在用 docker run 命令�建和启�容器�如何�布�例的端口，如在Deploy and Explore
InterSystems IRIS（《部署和探索 InterSystems IRIS》）中的Deploying InterSystems IRIS Community Edition on
Your Own System（在您自己的系�上部署 InterSystems IRIS 社区版）中所述。�个例子，如果您把�例的 web
服�器端口（始�是 52773）�布�
52773（如引用部分所述），并且您的��器与容器在同一个系�上运行，那么管理門�的 URL 是
http:/localhost:52773/csp/sys/UtilHome.csp。

有关�任何社区版�例打开�端的信息，�参�Deploy and Explore InterSystems IRIS（《部署和探索
InterSystems IRIS》）中的Interacting Using InterSystems Terminal（使用 InterSystems �端�行交互）。
IDE �接和管理門�的凭�是�定�用���之一，以及您在第一次�接云�点修改密��提供的新的默�密�[�
参�Deploy and Explore InterSystems IRIS（《部署和探索 InterSystems IRIS》）中的Change the Default
Passwords（修改默�密�）]，或者默�密�
SYS，如果您在自己的系�上或者在没有先�接到�点的情况下登�到云�例。当您使用 SYS �，系�会提示您
 
ObjectScript IDE

立即修改您所使用的��的密�。您也可以使用您以前在�例上�建的��。
您始�可以将您的 IDE �接到存在于所有 InterSystems IRIS �例中的USER
namespace，但您也可以�接到您以前使用管理門��建的不同namespace。

2.5   InterSystems 学���室（Learning Labs）
到容器化 InterSystems IRIS �例的所有�接都是您的 InterSystems 学���室（learning
labs）配置的一部分，在学���室启�期�，您需要的所有�接信息都�示在启��面上，如下所示：
•   集成 IDE 的 URL。
•   一套用于所有目的的凭�。
•   管理門� URL。
•   Web 服�器端口号（始�是 80）。
•   在外部�接下，服�器的 IP 地址和超�服�器的端口号（��� InterSystems IP 和 InterSystems

Page 4 of 8

http://host:webserverport/csp/sys/UtilHome.csp
http://localhost:52773/csp/sys/UtilHome.csp
http://40.122.36.160:52773/csp/sys/UtilHome.csp


IRIS 2021 技�文档 First Look 3 - �接一个IDE
Published on InterSystems Developer Community (https://community.intersystems.com)

端口)；您可以用它�将 IDE（如 InterSystems Studio 或 Visual Studio Code）与 ObjectScript �展�接到�例。

在集成 IDE 的 InterSystems 菜�上有一个Terminal��（Management Portal
��也是如此），所以您不需要跟踪�例名称。

3   ObjectScript IDE
本�介�了您可以用来在 InterSystems IRIS �例上开� ObjectScript 代�的 IDE：�有 ObjectScript �展的 Visual
Studio Code (VS Code)，以及 Studio。

3.1   Visual Studio Code
Visual Studio Code（VS Code）是微�� Windows、Linux 和 macOS
制作的一个免�源代���器。虽然它可以作��有 InterSystems IRIS 的.NET、Python 或 JavaScript IDE
开箱即用，但可用的�展功能使您能够使用 VS Code 开� ObjectScript
代�，�些代�在客�端系�上存�和版本化，在 InterSystems IRIS
服�器上��、运行和��。关于安装�展，�接到一个或多个 InterSystems IRIS �例，以及使用 VS Code for
ObjectScript 的信息，��� https://intersystems-community.github.io/vscode- objectscript/。 VS Code
可以�接到任何 InterSystems IRIS �例，无���例在哪个平台上运行，使用主机的 DNS 名称或 IP
地址、�例的名称和�例的超�服�器端口号，默�� 1972（但如果系�上安装了多个�例，�可能不同）。

3.2   Studio
InterSystems IRIS �用程序开�人��可以使用 Studio IDE，�是一个在 Windows
系�上运行的客�端�用程序；��信息�参�使用 Studio 。Studio 可以�接到任何 InterSystems IRIS
�例，无���例在哪个平台上运行，使用主机的 DNS 名称或 IP
地址、�例的名称和�例的超�服�器端口号，默�� 1972（但如果系�上安装了多个�例，�可能有所不同）。
 
Java IDE

4   Java IDE
本�提供了 Visual Studio Code （�有 Java ��包或 Java �展包）、Eclipse、IntelliJ 和 NetBeans
的�接�明，您可以用它�来开� Java 代�，使用 InterSystems Native API、JDBC 和 Java 网关与 InterSystems
IRIS 交互。

4.1   Visual Studio Code
要将 Visual Studio Code �接到 InterSystems IRIS，�使用以下步�。(如有必要，�登� GitHub。)
1.   在您的 web ��器中，下�或克隆 https://github.com/intersystems/Samples-java-helloworld。
2.   在 Visual Studio Code 中，使用 File > Open Folder 来打开您最近从 GitHub 下�或克隆的文件夹。
3.   ��并打开 src/main/java.com.intersystems.samples.helloworld.java。
4.   在主要方法的�部的�量声明中，�您的�例配置用�名、密�、IP 地址和端口（�参� InterSystems IRIS
Connection Information《InterSystems IRIS �接信息》)。�些�用于构造 InterSystems JDBC
�接字符串，格式� jdbc:IRIS://ipAddress:superserverPort/namespace, 例如
jdbc:IRIS://12.345.678.910:51773/USER。
5.   使用 View > Terminal 来打开�端并�行以下命令：

javac -cp ".:intersystems-jdbc-3.2.0.jar" HelloWorld.java java -cp ".:intersystems-jdbc-3.2.0.jar" HelloWorld

6.   �出窗格�示信息 Hello World! You have successfully connected to InterSystems IRIS via JDBC.

4.2   Eclipse
要将 Eclipse �接到 InterSystems IRIS，�使用以下步�。(点�
Next，根据需要推�到每个��框的下一个面板。)
首先，�入示例包，
1.   �� File > Import > Git > Projects from Git。
2.   �� Clone URI。将 https://github.com/intersystems/Samples-java-helloworld 复制并粘�到 URI 字段中。
3.   �� master 分支，配置本地存�，然后�� Import existing Eclipse projects。
4.   点� Finish 确��入。

接下来，更新示例代�并运行它。
1.   打开 samples-java-helloworld > src > main.java.com.intersystems.samples > HelloWorld.java 并做如下修改：
a.   将��包声明更改� package main.java.com.intersystems.samples;.
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b.   在主要方法的�部�量声明中，�您的�例配置用�名、密�、IP 地址和端口（�参� InterSystems IRIS
Connection Information《InterSystems IRIS �接信息》)。�些�用于构造 InterSystems JDBC
�接字符串，格式� jdbc:IRIS://ipAddress:superserverPort/namespace, 例如
jdbc:IRIS://12.345.678.910:1972/USER。

2.   通��� Run > Run 来运行代�。
 
Java IDE

3.   Console ���示的信息是 Hello World! You have successfully connected to InterSystems IRIS via JDBC.

如果您没有成功，�通�以下操作确� Java �行�境�置正确：
1.   右�点� Package Explorer 窗格中的 samples-java-helloworld �目，然后�� Build Path > Configure Build
Path...。
2.   在 Libraries ��上，�� Add Library > JRE System Library > Execution environment
>并��一个�行�境，如 JRE-1.1 (jre 1.8.0_172)。点� Finish，然后点� Apply and Close。

4.3   IntelliJ
要将 IntelliJ �接到 InterSystems IRIS，�使用以下步�。(点� Next，根据需要推�到每个��框的下一个面板。)
首先，�建示例�目。
1.   �� VCS > Checkout from Version Control > Git。
2.   在克隆存����框中，
a.   将 https://github.com/intersystems/Samples-java-helloworld 复制并粘�到 Clone URI 字段中。
b.   �于 Directory 字段，�入要�建本地 GitHub 存��的位置的路径。

3.   点� Clone，然后在�出的窗口中�� Yes ，以�建一个基于此源的�目。

接下来，更新示例代�并运行它。
1.   在主要方法的�部的�量声明中，打开 src/main/java.com.intersystems.samples.helloworld.java
并�您的�例配置用�名、密�、IP 地址和端口（�参� InterSystems IRIS Connection Information《InterSystems
IRIS �接信息》)。�些�用于构造 InterSystems JDBC �接字符串，格式�
jdbc:IRIS://ipAddress:superserverPort/namespace, 例如 jdbc:IRIS://12.345.678.910:1972/USER。
2.   在 Project 窗格中，右��� HelloWorld.java 并�� Run ‘HelloWorld.main()’。
3.   Output 窗格�示的信息是 Hello World! You have successfully connected to InterSystems IRIS via JDBC.

如果您没有成功，�通�以下操作确� Java �行�境�置正确：
1.   �� Build Path > Build Project。
2.   ��配置并添加一个新的�用程序配置，�� com.intersystems.samples.HelloWorld 作�主类。
3.   如果�� Error:java: invalid source release: 9 ��，在以下位置将�目 SDK 和�目�言�别修改� 1.8 ：
•   File > Project Structure > Project Settings
•   File > Project Structure > Module Settings > Sources: Language Level ��
•   File > Project Structure > Module Settings > Dependencies: Module SDK ��
 
.NET IDE

4.4   NetBeans
要将 NetBeans �接到 InterSystems IRIS，�使用以下步�。(点�
Next，根据需要推�到每个��框的下一个面板。)
首先，�建示例�目。
1.   �� Team > Git > Clone。
2.   将 https://github.com/intersystems/Samples-java-helloworld 复制粘�到 Repository URL 字段中。
3.   �� Master 作�要提取的分支，���建本地 GitHub 存��的位置，然后点� Finish。

接下来，更新示例代�并运行它。
1.   在主要方法的�部的�量声明中，打开 HelloWorld.java 并�您的�例配置用�名、密�、IP
地址和端口（�参� InterSystems IRIS Connection Information《InterSystems IRIS �接信息》)。�些�用于构造
InterSystems JDBC �接字符串，格式� jdbc:IRIS://ipAddress:superserverPort/namespace, 例如
jdbc:IRIS://12.345.678.910:1972/USER。
2.   在 Project 窗格中，打开 Dependencies 文件夹，然后右�点� intersystems-jdbc-3.0.0.jar 并�� Manually
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install artifact。�航到您最近克隆的文件夹，�� intersystems-jdbc-3.0.0.jar，然后点� Install Locally。
3.   在 Project 窗格中，右��� HelloWorld.java 并�� Run File。
4.   Output 窗格�示的信息是 Hello World! You have successfully connected to InterSystems IRIS via JDBC.

5   .NET IDE
本��微�的 Visual Studio 和 Visual Studio Code 提供�接�明，您可以用它来开�.NET 代�，�些代�通�
InterSystems Native API、ADO.NET Managed Provider for .NET、InterSystems XEP 和.NET 网关与 InterSystems
IRIS 交互。

5.1   Visual Studio
要将 Visual Studio �接到 InterSystems IRIS，�使用以下步�。(如有必要，�登� GitHub。)
首先，�建示例解决方案。
1.   �� View > Team Explorer。
2.   在 Team Explorer ‒ Connect 窗格中, �� Local Git Repositories > Clone, 将 https://github.com/inter-
systems/Samples-dotnet-helloworld 复制粘�到 URL 框中, 并点� Clone。

接下来，更新示例代�并运行它。
1.   双� HelloWorld.sln 来�看解决方案中的文件，然后打开 helloworld.cs。
2.   使用�量声明，�您的�例配置用�名、密�、IP 地址和端口（�参� InterSystems IRIS Connection
Information《InterSystems IRIS �接信息》)，
3.   按 F5 �，运行�程序。
 
Python IDE

4.   命令窗口�示的信息是 Hello World! You have successfully connected to InterSystems IRIS. Press any key to
continue.

5.2   Visual Studio Code
通� ObjectScript �展，Visual Studio Code 可以用来在 InterSystems IRIS 上开� ObjectScript
代�；�参�ObjectScript IDE。
要将 Visual Studio Code �接到 InterSystems IRIS，�使用以下步�。(如有必要，�登� GitHub。)
1.   在您的 web ��器中，下�或克隆 https://github.com/intersystems/Samples-dotnet-helloworld。
2.   在 Visual Studio Code 中，使用 File > Open Folder 来打开您最近从 GitHub 下�或克隆的文件夹。
3.   拓展 samples-dotnet-helloworld 并�� helloworld.cs。
4.   使用�量声明，�您的�例配置用�名、密�、IP 地址和端口（�参� InterSystems IRIS Connection
Information《InterSystems IRIS �接信息》)。
5.   使用 View > Terminal 来打开�端并�行以下命令：

csc /reference:InterSystems.Data.IRISClient.dll helloworld.cs
.\helloworld.exe

6.   �出窗格�示的信息是 Hello World! You have successfully connected to InterSystems IRIS.Press any key to
continue.

6   Python IDE
本�提供了将您最喜�的以 Python �中心的 IDE（如 Visual Studio Code、PyCharm、Spyder、IDLE/IdleX 或
Vim）�接到 InterSystems IRIS 的�明。当您使用以下步��接后（如有必要，�登�
GitHub），您可以使用技�概要:InterSystems IRIS Native API for Python 来探索 InterSystems IRIS Native API for
Python。
1.   在您的 web ��器中，下�或克隆 https://github.com/intersystems/Samples-python-helloworld。
2.   在您的 IDE 中，打开您最近从 GitHub 下�或克隆的文件夹，然后打开 hello_world.py。
3.   使用�量声明，�您的�例配置用�名、密�、IP 地址和端口（�参� InterSystems IRIS Connection
Information《InterSystems IRIS �接信息》)。
4.   在您的 IDE 的�端，做如下操作：
a.   使用以下命令之一安装 InterSystems Native API for Python:
•   微� Windows:
pip install wheel\irisnative-1.0.0-cp34.cp35.cp36.cp37-none-win_amd64.whl

•   UNIX®/Linux:
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pip install wheel/irisnative-1.0.0-cp34-abi3-linux_x86_64.whl

•   Apple macOS:
pip install wheel/irisnative-1.0.0-cp34-abi3-macosx_10_13_x86_64.macosx_10_14_x86_64.whl

b.   使用命令 python hello_world.py 运行代�。
 
Javascript IDE

5.   �出窗格�示信息 Hello World! You have successfully connected to InterSystems IRIS.

注意：   Python 代�示例和支持�文件是� Python 3 ��的，因� Python 2 将在 2020 年退休；Python 2
版本可从 InterSystems Learning Services �得。

7   Javascript IDE
本�提供了将您最喜�的 JavaScript 和 Node.js 的 IDE（如 Visual Studio Code、Vim 或 Webstorm）�接到
InterSystems IRIS 的�明。当您使用以下步��接后（如有必要，�登�
GitHub），您可以使用技�概要：InterSystems IRIS Native API for Node.js 来探索 InterSystems IRIS Native API
for Node.js。
1.   在您的 web ��器中，下�或克隆 https://github.com/intersystems/Samples-nodejs-helloworld。
2.   在您的 IDE 中，打开您最近从 GitHub 下�或克隆的文件夹，然后打开 hello_world.js。
3.   使用�量声明，�您的�例配置用�名、密�、IP 地址和端口（�参� InterSystems IRIS Connection
Information《InterSystems IRIS �接信息》)。
4.   在您的 IDE 的�端，做如下操作：
a.   使用命令 npm install ‒‒save intersystems-iris-native 安装 InterSystems Native API for Node.js。
b.   使用命令 node hello_world.js 运行代�。

5.   �出窗格�示信息 Hello World! You have successfully connected to InterSystems IRIS.
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